Vulnerability · Published Jun 22, 2026 · Assigned by canonical

CVE-2026-12249Canonical ADSys Trust Store Poisoning via Plaintext HTTP Certificate Auto-Enrollment

High 8.3

In plain English

A high-severity security flaw in adsys. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.1%top 96.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An issue was discovered in Canonical ADSys upstream versions through v0.16.2. During Active Directory Certificate Services (AD CS) certificate auto-enrollment via the vendored Samba client script (internal/policies/certificate/python/vendor_samba/gp/gp_cert_auto_enroll_ext.py), ADSys utilizes a plaintext HTTP connection (http://) instead of a secure HTTPS connection (https://) to request the CA certificate from the Active Directory Certificate Services server (GetCACert). An unauthenticated network attacker positioned between the managed Ubuntu host and the configured AD CS CA hostname can conduct a Man-in-the-Middle (MITM) attack. By intercepting the plaintext HTTP request, the attacker can supply an arbitrary, attacker-controlled Root CA certificate. Because the system automatically accepts this certificate and registers it into the local system trust store via update-ca-certificates, this results in system-wide trust store poisoning. Consequently, TLS clients utilizing the operating system trust store on the affected machine will accept rogue certificates for arbitrary domains, enabling persistent decryption and interception of subsequent TLS connections. This issue is resolved in version v0.16.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/ubuntu/adsys0.16.3-0.20250318112551-8b1939f96d38GHSA-crm4-q7v4-c2r2
Gogithub.com/ubuntu/adsysno fix listedGO-2026-6543
Ubuntu:25.10adsys0.16.3UBUNTU-CVE-2026-12249

Affected products (as reported)

VendorProductVersions
adsys 0.13.0 – before 0.16.3
Canonical Ubuntu 20.04 LTS see references
Canonical Ubuntu 22.04 LTS see references
Canonical Ubuntu 24.04 LTS see references
Canonical Ubuntu 25.10 see references
Canonical Ubuntu 26.04 LTS see references

Weakness: CWE-348 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

References