Vulnerability · Published Oct 19, 2026 · Assigned by GitHub_M
CVE-2026-112892Pillow: MSP RLE decoder expands a tiny file into unbounded memory
High 8.7
In plain English
A high-severity security flaw in Pillow from python-pillow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Pillow is a Python imaging library. From 4.1.0 until 13.0.0, Pillow's MSP RLE decoder can expand a small file into an unbounded in-memory buffer. The decoder writes run-length output to BytesIO without limiting expansion to the declared image size. An attacker can supply a crafted MSP image to an application that loads its pixels. This can exhaust memory and deny service even when the declared pixel count passes the decompression-bomb check. This issue is fixed in version 13.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | python3-pillow | 5.1.1-33.el8_10 | ALSA-2026:92639 |
| AlmaLinux:8 | python3-pillow-devel | 5.1.1-33.el8_10 | ALSA-2026:92639 |
| AlmaLinux:8 | python3-pillow-doc | 5.1.1-33.el8_10 | ALSA-2026:92639 |
| AlmaLinux:8 | python3-pillow-tk | 5.1.1-33.el8_10 | ALSA-2026:92639 |
| Debian:12 | pillow | no fix listed | DEBIAN-CVE-2026-112892 |
| Debian:13 | pillow | no fix listed | DEBIAN-CVE-2026-112892 |
| Debian:14 | pillow | no fix listed | DEBIAN-CVE-2026-112892 |
| PyPI | pillow | 13.0.0 | GHSA-gg2r-wvfm-q9rx |
| Rocky Linux:8 | python-pillow | 0:5.1.1-33.el8_10 | RLSA-2026:92639 |
| Ubuntu:22.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112892 |
| Ubuntu:24.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112892 |
| Ubuntu:26.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112892 |
| Ubuntu:26.10 | pillow | no fix listed | UBUNTU-CVE-2026-112892 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| python-pillow | Pillow | >= 4.1.0, < 13.0.0 |
Weakness: CWE-409 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N