Vulnerability · Published Oct 14, 2026 · Assigned by VulDB
CVE-2026-110679OpenSIPS rtpproxy rtpproxy_answer out-of-bounds
High 7.3
In plain English
A high-severity out-of-bounds read in OpenSIPS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
A vulnerability was determined in OpenSIPS up to 3.6.8/4.0.1. The impacted element is the function rtpproxy_offer/rtpproxy_answer of the component rtpproxy. This manipulation causes out-of-bounds read. The attack may be initiated remotely. Upgrading to version 3.6.9 and 4.0.2 is sufficient to resolve this issue. It is advisable to upgrade the affected component.
Affected products (as reported)
Weakness: CWE-125, CWE-119 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
References
- VDB-419834 | OpenSIPS rtpproxy rtpproxy_answer out-of-bounds vdb-entry, technical-description
- VDB-419834 | CTI Indicators (IOB, IOC, IOA) signature, permissions-required
- CVE-2026-110679 | CVE Analysis and Report third-party-advisory
- Submit #1003897 | OpenSIPS >= 4.0.0, < 4.0.2 and >= 3.6.0, < 3.6.9 rtpproxy: Unauthenticated out-of-bounds read SIP Call-ID din dtm third-party-advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qv9x-v8jq-434w related
- https://github.com/OpenSIPS/opensips/releases/tag/4.0.2 patch
- https://github.com/OpenSIPS/opensips/ product