Vulnerability · Published Oct 20, 2026 · Assigned by openjs

CVE-2026-110306fast-uri vulnerable to URI scheme spoofing via percent-encoded scheme decoding

Medium 6.1

In plain English

A medium-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.2%top 83.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, fast-uri percent-decodes the scheme component with the legacy global unescape() function before validating it, so an input whose decoded scheme is a dangerous token is emitted as a live scheme even though RFC 3986 does not allow percent-encoding in a scheme and no other parser accepts it. An application that screens dangerous schemes on the raw input and then stores or renders the normalized or resolved result can turn an inert string into an executable javascript, data, or vbscript URL, producing a stored or reflected cross-site scripting vector, and the equal() comparison treats an encoded and a plain scheme as the same, which can bypass equality-based allowlists. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject input whose scheme part contains a percent sign, or check the parsed scheme against an allowlist after normalization and use that same parsed result rather than the raw string.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-ajvno fix listedDEBIAN-CVE-2026-110306
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-110306
Debian:14node-ajv8.20.0~ds+~cs7.2.4-1DEBIAN-CVE-2026-110306
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110306
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110306
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110306
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-110306
npmfast-uri4.2.3GHSA-w74x-v6f9-j3xg
npmfast-uri3.1.9GHSA-w74x-v6f9-j3xg
npmfast-uri2.4.8GHSA-w74x-v6f9-j3xg

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 0 – before 2.4.83.0.0 – before 3.1.94.0.0 – before 4.2.3

Weakness: CWE-172, CWE-180 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References