Vulnerability · Published Oct 15, 2026 · Assigned by openjs

CVE-2026-109869undici vulnerable to Denial of Service via unhandled error on excessive content-encodings

High 7.5

In plain English

A high-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 72.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2026-109869
Debian:13node-undicino fix listedDEBIAN-CVE-2026-109869
Debian:14node-undici8.12.2+dfsg+~cs3.2.3-1DEBIAN-CVE-2026-109869
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109869
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109869
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-109869
npmundici8.12.2GHSA-xjj6-f33q-929c
npmundici7.30.1GHSA-xjj6-f33q-929c
npmundici6.29.1GHSA-xjj6-f33q-929c

Affected products (as reported)

VendorProductVersions
undici undici 6.23.0 – before 6.29.17.18.0 – before 7.30.18.0.0 – before 8.12.2

Weakness: CWE-248, CWE-459 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References