Vulnerability · Published Oct 7, 2026 · Assigned by GitHub_M

CVE-2026-106580ImageMagick: Policy Bypass in CUT encoder

Medium 4.0

In plain English

A medium-severity improper access control in ImageMagick from ImageMagick. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.0Medium
Exploit odds (30 days)0.3%top 80.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to 7.1.2-31 and 6.9.13-56, a missing security-policy check in the CUT encoder allows a crafted local encoding operation to read data that policy should deny and can also cause a crash. This issue is fixed in versions 7.1.2-31 and 6.9.13-56.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12imagemagick8:6.9.11.60+dfsg-1.6+deb12u14DEBIAN-CVE-2026-106580
Debian:13imagemagick8:7.1.1.43+dfsg1-1+deb13u13DEBIAN-CVE-2026-106580
Debian:14imagemagick8:7.1.2.31+dfsg1-1DEBIAN-CVE-2026-106580

Affected products (as reported)

VendorProductVersions
ImageMagick ImageMagick < 6.9.13-56>= 7.0.0, < 7.1.2-31

Weakness: CWE-284, CWE-400 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

References