Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-102829simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection

Critical 9.2

In plain English

A critical-severity OS command injection in git-js from steveukx. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.4%top 70.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@simple-git/argv-parser2.0.1GHSA-v5rq-49vh-5v5c

Affected products (as reported)

VendorProductVersions
steveukx git-js < 2.0.1

Weakness: CWE-78, CWE-184 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References