Vulnerability · Published Sep 26, 2026 · Assigned by VulnCheck
CVE-2026-100696Adminer before 6.0.2 Unauthenticated SSRF via Elasticsearch Driver
Medium 5.8
In plain English
A medium-severity server-side request forgery in adminer from vrana. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Adminer 4.16.0 through 6.0.1 contain a pre-authentication Server-Side Request Forgery (SSRF) vulnerability in the optional Elasticsearch driver (plugins/drivers/elastic.php), fixed in 6.0.2. Because adminer/include/auth.inc.php invokes Driver::connect() before the login result is validated, an unauthenticated attacker who submits crafted auth[server], auth[username], and auth[password] parameters can cause the Adminer server to issue an HTTP GET request (via get_url()/file_get_contents()) to an arbitrary reachable host and port. The driver validates only general server syntax and does not block loopback, private, link-local, or other reserved addresses; if no port is given it appends the default 9200, and Adminer's generic port check rejects ports below 1024. Selected JSON error fields from non-2xx Elasticsearch-style responses, as well as connection failures, are rendered on the login page, providing a port-scanning oracle and enabling internal network reconnaissance and service fingerprinting. Exploitation requires that the optional Elasticsearch driver be explicitly deployed (e.g., via the adminer/elastic.php template or an adminer_object() configuration; it is not loaded in a default build) and that PHP allow_url_fopen be enabled.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | adminer | no fix listed | DEBIAN-CVE-2026-100696 |
| Debian:13 | adminer | no fix listed | DEBIAN-CVE-2026-100696 |
| Debian:14 | adminer | 6.0.2-1 | DEBIAN-CVE-2026-100696 |
| Ubuntu:22.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-100696 |
| Ubuntu:24.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-100696 |
| Ubuntu:26.04:LTS | adminer | no fix listed | UBUNTU-CVE-2026-100696 |
| Ubuntu:26.10 | adminer | no fix listed | UBUNTU-CVE-2026-100696 |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
References
- GitHub Security Advisory (GHSA-q8h3-4cx4-prgm) vendor-advisory
- VulnCheck Advisory: Adminer before 6.0.2 Unauthenticated SSRF via Elasticsearch Driver third-party-advisory