Vulnerability · Published Oct 15, 2026 · Assigned by GitHub_M

CVE-2026-100409OpenNext Cloudflare: Cache interception can bypass middleware protection for encoded paths

High 7.5

In plain English

A high-severity security flaw in opennextjs-cloudflare from opennextjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 57.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenNext Cloudflare is an open Next.js adapter for Cloudflare. From 0.3.0 until 1.20.2, applications that enable enableCacheInterception, rely on middleware for access control, and have a matching cached protected route process encoded pathnames inconsistently between middleware matching and cache lookup. An unauthenticated attacker can use a percent-encoded pathname that does not match authorization middleware but decodes to the cache key of a protected route, causing cached content to be returned without authorization. Malformed encodings can also be partially decoded, allowing cache lookup to continue with a pathname that middleware did not evaluate consistently. This issue is fixed in version 1.20.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@opennextjs/cloudflare1.20.2GHSA-2vc4-c4r6-p6v6

Affected products (as reported)

VendorProductVersions
opennextjs opennextjs-cloudflare >= 0.3.0, < 1.20.2

Weakness: CWE-177, CWE-180 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References