Vulnerability · Published Nov 4, 2026 · Assigned by apache

CVE-2026-100300Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply thread

High 8.7

In plain English

A high-severity security flaw in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities).

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 58.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zookeeperno fix listedDEBIAN-CVE-2026-100300
Debian:13zookeeperno fix listedDEBIAN-CVE-2026-100300
Debian:14zookeeperno fix listedDEBIAN-CVE-2026-100300
Ubuntu:22.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100300
Ubuntu:24.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100300
Ubuntu:26.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-100300
Ubuntu:26.10zookeeperno fix listedUBUNTU-CVE-2026-100300

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ZooKeeper 3.9.0 – through 3.9.63.8.0 – through 3.8.7

Weakness: CWE-755 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References