Vulnerability · Published Sep 24, 2025 · Assigned by Wordfence
CVE-2025-9353Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
Medium 6.4
In plain English
A medium-severity cross-site scripting in Themify Builder from themifyme. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Official description
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| themifyme | Themify Builder | 0 – through 7.6.9 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js
- https://plugins.trac.wordpress.org/changeset/3366817/
- https://plugins.trac.wordpress.org/changeset/3355757/