Vulnerability · Published Jul 28, 2025 · Assigned by VulDB
CVE-2025-8260Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash
Low 3.1
In plain English
A low-severity broken cryptography in VaelsysV4 from Vaelsys. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities).
Official description
A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.
Affected products (as reported)
Weakness: CWE-328, CWE-327 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N/E:P/RL:O/RC:C
References
- VDB-317848 | Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash vdb-entry, technical-description
- VDB-317848 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #616922 | Vaelsys Vaelsys V4 v4.1.0 Unauthorized Access Leads to Sensitive Information Leakage third-party-advisory
- https://github.com/waiwai24/0101/blob/main/CVEs/Vaelsys/Unauthorized_Access_Leads_to_Sensitive_Information_Leakage_in_Vaelsys_V4_Platform.md exploit
- https://vaelsys.github.io/security-advisory/advisories/VSEC_V4_2025_07_0002.html patch