Vulnerability · Published Jul 30, 2025 · Assigned by AMZN
CVE-2025-8217Inert Malicious script injected into Amazon Q Developer Visual Studio Code (VS Code) Extension
Medium 4.0
In plain English
A medium-severity security flaw in Q Developer VS Code Extension from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities).
Official description
The Amazon Q Developer Visual Studio Code (VS Code) extension v1.84.0 contains inert, injected code designed to call the Q Developer CLI. The code executes when the extension is launched within the VS Code environment; however the injected code contains a syntax error which prevents it from making a successful API call to the Q Developer CLI. To mitigate this issue, users should upgrade to version v1.85.0. All installations of v1.84.0 should be removed from use.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | Q Developer VS Code Extension | 1.84.0 – before 1.85.0sha256:47f7840ecab6312d2733e1274c513050405886c70f2037fb2f1e9099872b0464 |
Weakness: CWE-506 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N