Vulnerability · Published Jul 4, 2025 · Assigned by VulDB

CVE-2025-7053Cockpit save cross site scripting

Low 3.5

In plain English

A low-severity cross-site scripting in Cockpit. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.4%top 70.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcockpit-hq/cockpit2.11.4GHSA-j4rj-fgcq-wmqp

Affected products (as reported)

VendorProductVersions
n/a Cockpit 2.11.02.11.12.11.22.11.3

Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N/E:X/RL:O/RC:C

References