Vulnerability · Published Jul 15, 2025 · Assigned by GitHub_P
CVE-2025-6981Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access
Medium 5.3
In plain English
A medium-severity incorrect authorization in Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | Enterprise Server | 3.14.0 – before 3.14.153.15.0 – before 3.15.103.16.0 – before 3.16.63.17.0 – before 3.17.3 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.15 release-notes
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.10 release-notes
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.6 release-notes
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.3 release-notes