Vulnerability · Published Jan 28, 2026 · Assigned by GitHub_M

CVE-2025-69289Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

Medium 5.1

In plain English

A medium-severity incorrect authorization in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities).

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.2%top 91.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Affected products (as reported)

VendorProductVersions
discourse discourse < 3.5.4>= 2025.11.0-latest, < 2025.11.2>= 2025.12.0-latest, < 2025.12.1>= 2026.1.0-latest, < 2026.1.0

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References