Vulnerability · Published Jan 7, 2026 · Assigned by GitHub_M

CVE-2025-69263pnpm Lockfile Integrity Bypass Allows Remote Dynamic Dependencies

High 7.5

In plain English

A high-severity security flaw in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 58.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

pnpm is a package manager. Versions 10.26.2 and below store HTTP tarball dependencies (and git-hosted tarballs) in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. An attacker who publishes a package with an HTTP tarball dependency can serve different code to different users or CI/CD environments. The attack requires the victim to install a package that has an HTTP/git tarball in its dependency tree. The victim's lockfile provides no protection. This issue is fixed in version 10.26.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23pnpm10.33.4-r0ALPINE-CVE-2025-69263
npmpnpm10.26.0GHSA-7vhp-vf5g-r2fw

Affected products (as reported)

VendorProductVersions
pnpm pnpm < 10.26.0

Weakness: CWE-494 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References