Vulnerability · Published Jan 7, 2026 · Assigned by GitHub_M
CVE-2025-69222LibreChat is vulnerable to Server-Side Request Forgery due to missing restrictions
Critical 9.1
In plain English
A critical-severity server-side request forgery in LibreChat from danny-avila. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 4.6% (higher than 92% of all known vulnerabilities).
Official description
LibreChat is a ChatGPT clone with additional features. Version 0.8.1-rc2 is prone to a server-side request forgery (SSRF) vulnerability due to missing restrictions of the Actions feature in the default configuration. LibreChat enables users to configure agents with predefined instructions and actions that can interact with remote services via OpenAPI specifications, supporting various HTTP methods, parameters, and authentication methods including custom headers. By default, there are no restrictions on accessible services, which means agents can also access internal components like the RAG API included in the default Docker Compose setup. This issue is fixed in version 0.8.1-rc2.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| danny-avila | LibreChat | >= 0.8.1-rc2, 0.8.2-rc2 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L