Vulnerability · Published Jan 13, 2026 · Assigned by GitHub_M
CVE-2025-68698Jervis has an RSA PKCS#1 v1.5 Padding Vulnerability
High 8.7
In plain English
A high-severity broken cryptography in jervis from samrocketman. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses PKCS1Encoding which is vulnerable to Bleichenbacher padding oracle attacks. Modern systems should use OAEP (Optimal Asymmetric Encryption Padding). This vulnerability is fixed in 2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | net.gleske:jervis | 2.2 | GHSA-mqw7-c5gg-xq97 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| samrocketman | jervis | < 2.2 |
Weakness: CWE-327 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N