Vulnerability · Published Dec 22, 2025 · Assigned by GitHub_M
CVE-2025-68476KEDA has Arbitrary File Read via Insufficient Path Validation in HashiCorp Vault Service Account Credential
High 8.2
In plain English
A high-severity path traversal in keda from kedacore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
KEDA is a Kubernetes-based Event Driven Autoscaling component. Prior to versions 2.17.3 and 2.18.3, an Arbitrary File Read vulnerability has been identified in KEDA, potentially affecting any KEDA resource that uses TriggerAuthentication to configure HashiCorp Vault authentication. The vulnerability stems from an incorrect or insufficient path validation when loading the Service Account Token specified in spec.hashiCorpVault.credential.serviceAccount. An attacker with permissions to create or modify a TriggerAuthentication resource can exfiltrate the content of any file from the node's filesystem (where the KEDA pod resides) by directing the file's content to a server under their control, as part of the Vault authentication request. The potential impact includes the exfiltration of sensitive system information, such as secrets, keys, or the content of files like /etc/passwd. This issue has been patched in versions 2.17.3 and 2.18.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/kedacore/keda | no fix listed | GO-2025-4257 |
| Go | github.com/kedacore/keda/v2 | 2.18.3 | GHSA-c4p6-qg4m-9jmr |
| Go | github.com/kedacore/keda/v2 | 2.17.3 | GHSA-c4p6-qg4m-9jmr |
| Go | github.com/kedacore/keda/v2 | 2.17.3, 2.18.3 | GO-2025-4257 |
Affected products (as reported)
Weakness: CWE-22, CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N