Vulnerability · Published Feb 5, 2026 · Assigned by GitHub_M
CVE-2025-68458webpack buildHttp: allowedUris allow-list bypass via URL userinfo (@) leading to build-time SSRF behavior
Low 3.7
In plain English
A low-severity server-side request forgery in webpack from webpack. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Webpack is a module bundler. From version 5.49.0 to before 5.104.1, when experiments.buildHttp is enabled, webpack’s HTTP(S) resolver (HttpUriPlugin) can be bypassed to fetch resources from hosts outside allowedUris by using crafted URLs that include userinfo (username:password@host). If allowedUris enforcement relies on a raw string prefix check (e.g., uri.startsWith(allowed)), a URL that looks allow-listed can pass validation while the actual network request is sent to a different authority/host after URL parsing. This is a policy/allow-list bypass that enables build-time SSRF behavior (outbound requests from the build machine to internal-only endpoints, depending on network access) and untrusted content inclusion (the fetched response is treated as module source and bundled). This issue has been patched in version 5.104.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-webpack | no fix listed | DEBIAN-CVE-2025-68458 |
| Debian:13 | node-webpack | no fix listed | DEBIAN-CVE-2025-68458 |
| Debian:14 | node-webpack | 5.105.4+dfsg1+~cs15.13.23-2 | DEBIAN-CVE-2025-68458 |
| Ubuntu:22.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2025-68458 |
| Ubuntu:24.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2025-68458 |
| Ubuntu:25.10 | node-webpack | no fix listed | UBUNTU-CVE-2025-68458 |
| Ubuntu:26.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2025-68458 |
| Ubuntu:26.10 | node-webpack | no fix listed | UBUNTU-CVE-2025-68458 |
| npm | webpack | 5.104.1 | GHSA-8fgc-7cc6-rx7x |
Affected products (as reported)
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/webpack/webpack/security/advisories/GHSA-8fgc-7cc6-rx7x x_refsource_CONFIRM