Vulnerability · Published Dec 26, 2025 · Assigned by GitHub_M
CVE-2025-67729lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()
High 8.8
In plain English
A high-severity unsafe deserialization in lmdeploy from InternLM. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | lmdeploy | 0.11.1 | GHSA-9pf3-7rrr-x5jh |
| PyPI | lmdeploy | 0.11.1 | PYSEC-2026-1578 |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H