Vulnerability · Published Jan 15, 2026 · Assigned by GitHub_M

CVE-2025-67647SvelteKit Denial of service and possible SSRF when using prerendering

High 8.4

In plain English

A high-severity server-side request forgery in kit from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.4High
Exploit odds (30 days)0.5%top 55.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@sveltejs/adapter-node5.5.1GHSA-j62c-4x62-9r35
npm@sveltejs/kit2.49.5GHSA-j62c-4x62-9r35

Affected products (as reported)

VendorProductVersions
sveltejs kit >= 2.19.0, < 2.49.5

Weakness: CWE-248, CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N

References