Vulnerability · Published Dec 5, 2025 · Assigned by GitHub_M
CVE-2025-66562TUUI vulnerable to Remote Code Execution (RCE) via XSS in Markdown ECharts Rendering
High 8.9
In plain English
A high-severity cross-site scripting in tuui from AI-QL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Official description
TUUI is a desktop MCP client designed as a tool unitary utility integration. Prior to 1.3.4, a critical Remote Code Execution (RCE) vulnerability exists in Tuui due to an unsafe Cross-Site Scripting (XSS) flaw in the Markdown rendering component. Tuui allows the execution of arbitrary JavaScript within ECharts code blocks. Combined with an exposed IPC interface that allows spawning processes, an attacker can execute arbitrary system commands on the victim's machine simply by having them view a malicious Markdown message. This vulnerability is fixed in 1.3.4.
Affected products (as reported)
Weakness: CWE-79, CWE-94 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/AI-QL/tuui/security/advisories/GHSA-qjhq-rgmr-6c3g x_refsource_CONFIRM
- https://github.com/AI-QL/tuui/commit/f673fa5b4d76e8236c7d9506d0727875cfa79cc1 x_refsource_MISC
- https://github.com/AI-QL/tuui/releases/tag/v1.3.4 x_refsource_MISC