Vulnerability · Published Dec 4, 2025 · Assigned by GitHub_M
CVE-2025-66561SysReptor Vulnerable to an Authenticated Stored Cross-Site Scripting (XSS)
High 7.3
In plain English
A high-severity cross-site scripting in sysreptor from Syslifters. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities).
Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.2%top 89.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
SysReptor is a fully customizable pentest reporting platform. Prior to 2025.102, there is a Stored Cross-Site Scripting (XSS) vulnerability allows authenticated users to execute malicious JavaScript in the context of other logged-in users by uploading malicious JavaScript files in the web UI. This vulnerability is fixed in 2025.102.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Syslifters | sysreptor | < 2025.102 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/Syslifters/sysreptor/security/advisories/GHSA-64vw-v5c4-mgvm x_refsource_CONFIRM