Vulnerability · Published Dec 4, 2025 · Assigned by apache
CVE-2025-66516Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected
High 8.4
In plain English
A high-severity XML external entity in Apache Tika core from Apache Software Foundation. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 89.0% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways. First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable. Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.tika:tika-core | 3.2.2 | GHSA-f58c-gq56-vjjf |
| Maven | org.apache.tika:tika-parser-pdf-module | 3.2.2 | GHSA-f58c-gq56-vjjf |
| Maven | org.apache.tika:tika-parsers | 2.0.0 | GHSA-f58c-gq56-vjjf |
| Ubuntu:22.04:LTS | tika | 1.22-2+deb11u1build0.22.04.1 | USN-8324-1 |
| Ubuntu:22.04:LTS | tika | 1.22-2+deb11u1build0.22.04.1 | UBUNTU-CVE-2025-66516 |
| Ubuntu:24.04:LTS | tika | no fix listed | UBUNTU-CVE-2025-66516 |
| Ubuntu:25.10 | tika | no fix listed | UBUNTU-CVE-2025-66516 |
| Ubuntu:26.04:LTS | tika | no fix listed | UBUNTU-CVE-2025-66516 |
| Ubuntu:26.10 | tika | no fix listed | UBUNTU-CVE-2025-66516 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tika core | 1.13 – through 3.2.1 |
| Apache Software Foundation | Apache Tika parsers | 1.13 – before 2.0.0 |
| Apache Software Foundation | Apache Tika PDF parser module | 2.0.0 – through 3.2.1 |
Weakness: CWE-611 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H