Vulnerability · Published Dec 3, 2025 · Assigned by GitHub_M
CVE-2025-66404mcp-server-kubernetes potential security issue in exec_in_pod tool
Medium 6.4
In plain English
A medium-severity command injection in mcp-server-kubernetes from Flux159. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. Prior to 2.9.8, there is a security issue exists in the exec_in_pod tool of the mcp-server-kubernetes MCP Server. The tool accepts user-provided commands in both array and string formats. When a string format is provided, it is passed directly to shell interpretation (sh -c) without input validation, allowing shell metacharacters to be interpreted. This vulnerability can be exploited through direct command injection or indirect prompt injection attacks, where AI agents may execute commands without explicit user intent. This vulnerability is fixed in 2.9.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | mcp-server-kubernetes | 2.9.8 | GHSA-wvxp-jp4w-w8wg |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Flux159 | mcp-server-kubernetes | < 2.9.8 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H