Vulnerability · Published Nov 29, 2025 · Assigned by GitHub_M
CVE-2025-66036Retro is vulnerable to XSS vulnerability in input handling component
Medium 6.1
In plain English
A medium-severity cross-site scripting in Retro from Anjaliavv51. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities).
Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.2%top 89.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Retro is an online platform providing items of vintage collections. Prior to version 2.4.7, Retro is vulnerable to a cross-site scripting (XSS) in the input handling component. This issue has been patched in version 2.4.7.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Anjaliavv51 | Retro | < 2.4.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/Anjaliavv51/Retro/security/advisories/GHSA-gvv6-p6h6-2vj2 x_refsource_CONFIRM