Vulnerability · Published Nov 19, 2025 · Assigned by GitHub_M

CVE-2025-65099Claude Code vulnerable to command execution prior to startup trust dialog

High 7.7

In plain English

A high-severity code injection in claude-code from anthropics. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Claude Code is an agentic coding tool. Prior to version 1.0.39, when running on a machine with Yarn 3.0 or above, Claude Code could have been tricked to execute code contained in a project via yarn plugins before the user accepted the startup trust dialog. Exploiting this would have required a user to start Claude Code in an untrusted directory and to be using Yarn 3.0 or above. This issue has been patched in version 1.0.39.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@anthropic-ai/claude-code1.0.39GHSA-5hhx-v7f6-x7gv

Affected products (as reported)

VendorProductVersions
anthropics claude-code < 1.0.39

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References