Vulnerability · Published Feb 3, 2026 · Assigned by GitHub_M
CVE-2025-65017Decidim's private data exports can lead to data leaks
High 8.2
In plain English
A high-severity information exposure in decidim from decidim. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | decidim | 0.30.4 | GHSA-3cx6-j9j4-54mp |
| RubyGems | decidim-core | 0.30.4 | GHSA-3cx6-j9j4-54mp |
Affected products (as reported)
Weakness: CWE-200, CWE-703 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
References
- https://github.com/decidim/decidim/security/advisories/GHSA-3cx6-j9j4-54mp x_refsource_CONFIRM
- https://github.com/decidim/decidim/pull/13571 x_refsource_MISC
- https://github.com/decidim/decidim/releases/tag/v0.30.4 x_refsource_MISC
- https://github.com/decidim/decidim/releases/tag/v0.31.0 x_refsource_MISC