Vulnerability · Published Nov 18, 2025 · Assigned by GitHub_M
CVE-2025-65015joserfc has Possible Uncontrolled Resource Consumption Vulnerability Triggered by Logging Arbitrarily Large JWT Token Payloads
Critical 9.2
In plain English
A critical-severity resource allocation without limits in joserfc from authlib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. In versions from 1.3.3 to before 1.3.5 and from 1.4.0 to before 1.4.2, the ExceededSizeError exception messages are embedded with non-decoded JWT token parts and may cause Python logging to record an arbitrarily large, forged JWT payload. In situations where a misconfigured — or entirely absent — production-grade web server sits in front of a Python web application, an attacker may be able to send arbitrarily large bearer tokens in the HTTP request headers. When this occurs, Python logging or diagnostic tools (e.g., Sentry) may end up processing extremely large log messages containing the full JWT header during the joserfc.jwt.decode() operation. The same behavior also appears when validating claims and signature payload sizes, as the library raises joserfc.errors.ExceededSizeError() with the full payload embedded in the exception message. Since the payload is already fully loaded into memory at this stage, the library cannot prevent or reject it. This issue has been patched in versions 1.3.5 and 1.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | joserfc | 1.4.3-1 | DEBIAN-CVE-2025-65015 |
| PyPI | joserfc | 1.4.2 | GHSA-frfh-8v73-gjg4 |
| PyPI | joserfc | 1.3.5, 1.4.2 | PYSEC-2026-361 |
| PyPI | joserfc | 1.3.5 | GHSA-frfh-8v73-gjg4 |
| Ubuntu:25.10 | joserfc | no fix listed | UBUNTU-CVE-2025-65015 |
| Ubuntu:26.04:LTS | joserfc | no fix listed | UBUNTU-CVE-2025-65015 |
| Ubuntu:26.10 | joserfc | no fix listed | UBUNTU-CVE-2025-65015 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
References
- https://github.com/authlib/joserfc/security/advisories/GHSA-frfh-8v73-gjg4 x_refsource_CONFIRM
- https://github.com/authlib/joserfc/commit/63932f169d924caffafa761af2122b82059017f7 x_refsource_MISC
- https://github.com/authlib/joserfc/commit/673c8743fd0605b0e1de6452be6cba75f44e466b x_refsource_MISC
- https://github.com/authlib/joserfc/releases/tag/1.3.5 x_refsource_MISC
- https://github.com/authlib/joserfc/releases/tag/1.4.2 x_refsource_MISC