Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M

CVE-2025-64751OpenFGA Improper Policy Enforcement

Medium 5.8

In plain English

A medium-severity security flaw in openfga from openfga. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.8Medium
Exploit odds (30 days)0.3%top 75.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/openfga/openfga1.11.1GHSA-2c64-vmv2-hgfc
Gogithub.com/openfga/openfga1.11.1GO-2025-4150

Affected products (as reported)

VendorProductVersions
openfga openfga >= 1.4.0, < 1.11.1

Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

References