Vulnerability · Published Nov 19, 2025 · Assigned by apache
CVE-2025-64408Apache Causeway: Java deserialization vulnerability to authenticated attackers
Medium 6.3
In plain English
A medium-severity unsafe deserialization in Apache Causeway from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 11.6% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.causeway.commons:causeway-commons | 3.5.0 | GHSA-wq4c-57mh-5f7g |
| Maven | org.apache.causeway.core:causeway-applib | 3.5.0 | GHSA-wq4c-57mh-5f7g |
| Maven | org.apache.causeway.core:causeway-core | 3.5.0 | GHSA-wq4c-57mh-5f7g |
| Maven | org.apache.causeway.viewer:causeway-viewer-wicket | 3.5.0 | GHSA-wq4c-57mh-5f7g |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Causeway | 2.0.0 – through 3.4.04.0.0-M1 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L