Vulnerability · Published Oct 28, 2025 · Assigned by GitHub_M
CVE-2025-62801FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
Medium 5.4
In plain English
A medium-severity OS command injection in fastmcp from jlowin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | fastmcp | 2.13.0 | GHSA-rj5c-58rq-j5g5 |
| PyPI | fastmcp | 2.13.0 | PYSEC-2026-1365 |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-rj5c-58rq-j5g5 x_refsource_CONFIRM