Vulnerability · Published Oct 27, 2025 · Assigned by GitHub_M
CVE-2025-62783InventoryGui affected by item duplication in GUIs which use GuiStorageElement
Medium 5.0
In plain English
A medium-severity security flaw in InventoryGui from Phoenix616. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions 1.6.1-SNAPSHOT and earlier contain a vulnerability where any plugin using the `GuiStorageElement can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.2-SNAPSHOT.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | de.themoep:inventorygui | 1.6.2-SNAPSHOT | GHSA-598q-jw82-5w66 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Phoenix616 | InventoryGui | < 1.6.2-SNAPSHOT |
Weakness: CWE-837 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N