Vulnerability · Published Oct 22, 2025 · Assigned by GitHub_M
CVE-2025-62708pypdf manipulated LZWDecode streams can exhaust RAM
Medium 6.6
In plain English
A medium-severity security flaw in pypdf from py-pdf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream of a page using the LZWDecode filter. This has been fixed in pypdf version 6.1.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | pypdf | no fix listed | DEBIAN-CVE-2025-62708 |
| Debian:14 | pypdf | 6.9.0-1 | DEBIAN-CVE-2025-62708 |
| PyPI | pypdf | 6.1.3 | GHSA-jfx9-29x2-rv3j |
| PyPI | pypdf | 6.1.3 | PYSEC-2026-1831 |
| Ubuntu:24.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2025-62708 |
| Ubuntu:25.10 | pypdf | no fix listed | UBUNTU-CVE-2025-62708 |
| Ubuntu:26.04:LTS | pypdf | no fix listed | UBUNTU-CVE-2025-62708 |
| Ubuntu:26.10 | pypdf | no fix listed | UBUNTU-CVE-2025-62708 |
Affected products (as reported)
Weakness: CWE-409 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
References
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-jfx9-29x2-rv3j x_refsource_CONFIRM
- https://github.com/py-pdf/pypdf/pull/3502 x_refsource_MISC
- https://github.com/py-pdf/pypdf/commit/e51d07807ffcdaf18077b9486dadb3dc05b368da x_refsource_MISC
- https://github.com/py-pdf/pypdf/releases/tag/6.1.3 x_refsource_MISC