Vulnerability · Published Oct 22, 2025 · Assigned by GitHub_M
CVE-2025-62706Authlib : JWE zip=DEF decompression bomb enables DoS
Medium 6.5
In plain English
A medium-severity uncontrolled resource consumption in authlib from authlib. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. This issue has been patched in version 1.6.5. Workarounds for this issue involve rejecting or stripping zip=DEF for inbound JWEs at the application boundary, forking and add a bounded decompression guard via decompressobj().decompress(data, MAX_SIZE)) and returning an error when output exceeds a safe limit, or enforcing strict maximum token sizes and fail fast on oversized inputs; combine with rate limiting.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-authlib | 1.2.0-1+deb12u1 | DEBIAN-CVE-2025-62706 |
| Debian:13 | python-authlib | 1.6.0-1+deb13u1 | DEBIAN-CVE-2025-62706 |
| Debian:14 | python-authlib | 1.6.5-1 | DEBIAN-CVE-2025-62706 |
| PyPI | authlib | 1.6.5 | GHSA-g7f3-828f-7h7m |
| PyPI | authlib | 1.6.5 | PYSEC-2026-1202 |
| Ubuntu:25.10 | python-authlib | no fix listed | UBUNTU-CVE-2025-62706 |
Affected products (as reported)
Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H