Vulnerability · Published Oct 2, 2025 · Assigned by apache
CVE-2025-61735Apache Kylin: Server-Side Request Forgery
High 7.3
In plain English
A high-severity server-side request forgery in Apache Kylin from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected. Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.kylin:kylin | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-common-server | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-common-service | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-core-common | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-core-metadata | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-ops-server | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
| Maven | org.apache.kylin:kylin-server | 5.0.3 | GHSA-f6m8-qm7j-fh65 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Kylin | 4.0.0 – through 5.0.2 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L