Vulnerability · Published Oct 3, 2025 · Assigned by GitHub_M
CVE-2025-61677DataChain: Deserialization of Untrusted Data from Environment Variables
Low 2.5
In plain English
A low-severity unsafe deserialization in datachain from iterative. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | datachain | 0.34.2 | GHSA-6px8-mr29-cj4r |
| PyPI | datachain | 0.34.2 | PYSEC-2026-1288 |
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
References
- https://github.com/iterative/datachain/security/advisories/GHSA-6px8-mr29-cj4r x_refsource_CONFIRM
- https://github.com/iterative/datachain/pull/1358 x_refsource_MISC
- https://github.com/iterative/datachain/commit/914b95610620d50c8d9bee506ccbfa7d4d57fdc0 x_refsource_MISC