Vulnerability · Published Jan 10, 2026 · Assigned by GitHub_M
CVE-2025-61674October CMS Vulnerable to Stored XSS via Editor and Branding Styles
Medium 6.1
In plain English
A medium-severity cross-site scripting in october from octobercms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerability was identified in October CMS backend configuration forms. A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at Markup Styles. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | october/system | 3.7.13 | GHSA-gxxc-m74c-f48x |
| Packagist | october/system | 4.0.12 | GHSA-gxxc-m74c-f48x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| octobercms | october | >= 4.0.0, < 4.0.12< 3.7.13 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/octobercms/october/security/advisories/GHSA-gxxc-m74c-f48x x_refsource_CONFIRM