Vulnerability · Published Oct 8, 2025 · Assigned by GitHub_M

CVE-2025-61672Synapse: Invalid device keys degrade federation functionality

Medium 5.3

In plain English

A medium-severity security flaw in synapse from element-hq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.5%top 58.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Synapse is an open source Matrix homeserver implementation. Lack of validation for device keys in Synapse before 1.138.3 and in Synapse 1.139.0 allow an attacker registered on the victim homeserver to degrade federation functionality, unpredictably breaking outbound federation to other homeservers. The issue is patched in Synapse 1.138.3, 1.138.4, 1.139.1, and 1.139.2. Note that even though 1.138.3 and 1.139.1 fix the vulnerability, they inadvertently introduced an unrelated regression. For this reason, the maintainers of Synapse recommend skipping these releases and upgrading straight to 1.138.4 and 1.139.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22synapse1.139.2-r0ALPINE-CVE-2025-61672
Alpine:v3.23synapse1.139.2-r0ALPINE-CVE-2025-61672
Alpine:v3.24synapse1.139.2-r0ALPINE-CVE-2025-61672
Debian:14matrix-synapse1.139.2-1DEBIAN-CVE-2025-61672
PyPImatrix-synapse1.139.1GHSA-fh66-fcv5-jjfr
PyPImatrix-synapse1.138.3GHSA-fh66-fcv5-jjfr
PyPImatrix-synapse1.138.3, 1.139.1PYSEC-2026-1612
Ubuntu:24.04:LTSmatrix-synapseno fix listedUBUNTU-CVE-2025-61672

Affected products (as reported)

VendorProductVersions
element-hq synapse < 1.138.3= 1.139.0

Weakness: CWE-1287 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

References