Vulnerability · Published Oct 9, 2025 · Assigned by Wordfence
CVE-2025-6038Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme <= 1.4.0 - Authenticated (Subscriber+) Privilege Escalation
High 8.8
In plain English
A high-severity authorization bypass via user-controlled key in Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme from pebas. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities).
Official description
The Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme plugin for WordPress is vulnerable to privilege escalation via password update in all versions up to, and including, 1.4.0. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change arbitrary user's passwords, including those of administrators.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pebas | Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme | 0 – through 1.4.0 |
Weakness: CWE-639 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H