Vulnerability · Published Aug 1, 2025 · Assigned by HashiCorp
CVE-2025-6000Arbitrary Remote Code Execution via Plugin Catalog Abuse
Critical 9.1
In plain English
A critical-severity code injection in Vault from HashiCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)1.0%top 38.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A privileged Vault operator within the root namespace with write permission to {{sys/audit}} may obtain code execution on the underlying host if a plugin directory is set in Vault’s configuration. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/vault | 1.20.1 | GHSA-mr4h-qf9j-f665 |
| Go | github.com/hashicorp/vault | 1.20.1 | GO-2025-3838 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HashiCorp | Vault | 0.8.0 – before 1.20.1 |
| HashiCorp | Vault Enterprise | 0.8.0 – before 1.20.1 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H