Vulnerability · Published Oct 3, 2025 · Assigned by GitHub_M
CVE-2025-59944Cursor IDE: Sensitive File Overwrite Bypass is Possible
High 8.1
In plain English
A high-severity security flaw in cursor from cursor. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities).
Official description
Cursor is a code editor built for programming with AI. Versions 1.6.23 and below contain case-sensitive checks in the way Cursor IDE protects its sensitive files (e.g., */.cursor/mcp.json), which allows attackers to modify the content of these files through prompt injection and achieve remote code execution. A prompt injection can lead to full RCE through modifying sensitive files on case-insensitive fileystems. This issue is fixed in version 1.7.
Affected products (as reported)
Weakness: CWE-178 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/cursor/cursor/security/advisories/GHSA-xcwh-rrwj-gxc7 x_refsource_CONFIRM