Vulnerability · Published Sep 29, 2025 · Assigned by GitHub_M

CVE-2025-59933libvips is vulnerable to Buffer Over-Read in poppler-based pdfload

Medium 5.1

In plain English

A medium-severity security flaw in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.2%top 91.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vipsno fix listedDEBIAN-CVE-2025-59933
Debian:13vips8.16.1-1+deb13u2DEBIAN-CVE-2025-59933
Debian:14vips8.17.3-1DEBIAN-CVE-2025-59933
Ubuntu:25.10vipsno fix listedUBUNTU-CVE-2025-59933

Affected products (as reported)

VendorProductVersions
libvips libvips < 8.17.2

Weakness: CWE-126 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

References