Vulnerability · Published Jul 11, 2025 · Assigned by TQtC
CVE-2025-5992Passing values outside of expected range to QColorTransferGenericFunction can cause a denial of service
Low 2.3
In plain English
A low-severity improper input validation in Qt from Qt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
When passing values outside of the expected range to QColorTransferGenericFunction it can cause a denial of service, for example, this can happen when passing a specifically crafted ICC profile to QColorSpace::fromICCProfile. This issue affects Qt from 6.6.0 through 6.8.3, from 6.9.0 through 6.9.1. This is fixed in 6.8.4 and 6.9.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | qt6-base | no fix listed | DEBIAN-CVE-2025-5992 |
| Debian:13 | qt6-base | 6.8.2+dfsg-9 | DEBIAN-CVE-2025-5992 |
| Debian:14 | qt6-base | 6.8.2+dfsg-9 | DEBIAN-CVE-2025-5992 |
| Ubuntu:22.04:LTS | qt6-base | no fix listed | UBUNTU-CVE-2025-5992 |
| Ubuntu:24.04:LTS | qt6-base | no fix listed | UBUNTU-CVE-2025-5992 |
| Ubuntu:25.10 | qt6-base | no fix listed | UBUNTU-CVE-2025-5992 |
| Ubuntu:26.04:LTS | qt6-base | no fix listed | UBUNTU-CVE-2025-5992 |
| Ubuntu:26.10 | qt6-base | no fix listed | UBUNTU-CVE-2025-5992 |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L