Vulnerability · Published Sep 26, 2025 · Assigned by GitHub_M
CVE-2025-59845Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
High 8.2
In plain English
A high-severity cross-site request forgery in embeddable-explorer from apollographql. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @apollo/explorer | 3.7.3 | GHSA-w87v-7w53-wwxv |
| npm | @apollo/sandbox | 2.7.2 | GHSA-w87v-7w53-wwxv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| apollographql | embeddable-explorer | < 2.7.2< 3.7.3 |
Weakness: CWE-346, CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N