Vulnerability · Published Sep 25, 2025 · Assigned by GitHub_M

CVE-2025-59830Rack QueryParser has an unsafe default allowing params_limit bypass via semicolon-separated parameters

High 7.5

In plain English

A high-severity uncontrolled resource consumption in rack from rack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 52.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10cockpit-ha-cluster0.12.1-1.el10_1.1ALSA-2025:21036
AlmaLinux:8pcs0.10.18-2.el8_10.7.alma.1ALSA-2025:19719
AlmaLinux:9pcs0.11.10-1.el9_7.1ALSA-2025:20962
AlmaLinux:8pcs-snmp0.10.18-2.el8_10.7.alma.1ALSA-2025:19719
AlmaLinux:9pcs-snmp0.11.10-1.el9_7.1ALSA-2025:20962
Debian:12ruby-rack2.2.20-0+deb12u1DEBIAN-CVE-2025-59830
Debian:13ruby-rack3.0.8-2DEBIAN-CVE-2025-59830
Debian:14ruby-rack3.0.8-2DEBIAN-CVE-2025-59830
Rocky Linux:8pcs0:0.10.18-2.el8_10.7RLSA-2025:19719
Rocky Linux:9pcs0:0.11.10-1.el9_7.1RLSA-2025:20962
Rocky Linux:9pcs0:0.11.9-2.el9_6.2RLSA-2025:19512
RubyGemsrack2.2.18GHSA-625h-95r8-8xpm
Ubuntu:22.04:LTSruby-rack2.1.4-5ubuntu1.2UBUNTU-CVE-2025-59830
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.4USN-7784-1
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.4UBUNTU-CVE-2025-59830

Affected products (as reported)

VendorProductVersions
rack rack < 2.2.18

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References