Vulnerability · Published Oct 3, 2025 · Assigned by GitHub_M
CVE-2025-59829Claude Code: Permission deny bypass is possible through symlink
Low 2.3
In plain English
A low-severity security flaw in claude-code from anthropics. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Claude Code is an agentic coding tool. Versions below 1.0.120 failed to account for symlinks when checking permission deny rules. If a user explicitly denied Claude Code access to a file and Claude Code had access to a symlink pointing to that file, it was possible for Claude Code to access the file. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. This issue is fixed in version 1.0.120.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @anthropic-ai/claude-code | 1.0.120 | GHSA-66m2-gx93-v996 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| anthropics | claude-code | < 1.0.120 |
Weakness: CWE-61 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N