Vulnerability · Published Dec 5, 2025 · Assigned by apache

CVE-2025-59775Apache HTTP Server: NTLM Leakage on Windows through UNC SSRF

High 7.5

In plain English

A high-severity server-side request forgery in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 40.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Server-Side Request Forgery (SSRF) vulnerability  in Apache HTTP Server on Windows with AllowEncodedSlashes On and MergeSlashes Off  allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20apache22.4.66-r0ALPINE-CVE-2025-59775
Alpine:v3.21apache22.4.66-r0ALPINE-CVE-2025-59775
Alpine:v3.22apache22.4.66-r0ALPINE-CVE-2025-59775
Alpine:v3.23apache22.4.66-r0ALPINE-CVE-2025-59775
Alpine:v3.24apache22.4.66-r0ALPINE-CVE-2025-59775
Ubuntu:22.04:LTSapache2no fix listedUBUNTU-CVE-2025-59775
Ubuntu:24.04:LTSapache2no fix listedUBUNTU-CVE-2025-59775
Ubuntu:25.10apache2no fix listedUBUNTU-CVE-2025-59775

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 2.4.0 – through 2.4.65

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References